anlib

View on PyPIReverse Dependencies (0)

1.2 anlib-1.2-py2.py3-none-any.whl

Wheel Details

Project: anlib
Version: 1.2
Filename: anlib-1.2-py2.py3-none-any.whl
Download: [link]
Size: 4732
MD5: ca58f39c729dd74fad5e35892cb88b1f
SHA256: 74ac275a310b33cae7ad0baa74699644c2a2dbf4561d7d9aa92f634d64470120
Uploaded: 2021-02-28 03:04:20 +0000

dist-info

METADATA

Metadata-Version: 2.1
Name: anlib
Version: 1.2
Summary: A command line application to query and download from the Anarchist Library.
Author: Erik Tastepe
Author-Email: erik.tastepe[at]tuta.io
Home-Page: https://github.com/erik-tastepe/anlib
Project-Url: Source, https://github.com/erik-tastepe/anlib
Keywords: anarchism cli
Classifier: Development Status :: 4 - Beta
Classifier: Intended Audience :: Science/Research
Classifier: Topic :: Education
Classifier: License :: OSI Approved :: MIT License
Classifier: Programming Language :: Python :: 3.5
Classifier: Programming Language :: Python :: 3.6
Classifier: Programming Language :: Python :: 3.7
Classifier: Programming Language :: Python :: 3.8
Classifier: Programming Language :: Python :: 3.9
Requires-Python: >=3.5
Requires-Dist: beautifulsoup4 (==4.9.3)
Requires-Dist: certifi (==2020.12.5)
Requires-Dist: requests (==2.25.1)
Requires-Dist: idna (==2.10); python_version >= "2.7" and python_version not in "3.0, 3.1, 3.2, 3.3"
Requires-Dist: chardet (==4.0.0); python_version >= "2.7" and python_version not in "3.0, 3.1, 3.2, 3.3, 3.4"
Requires-Dist: urllib3 (==1.26.3); python_version >= "2.7" and python_version not in "3.0, 3.1, 3.2, 3.3, 3.4" and python_version < "4"
Requires-Dist: soupsieve (==2.2); python_version >= "3.0"
Requires-Dist: appdirs (==1.4.4); extra == "dev"
Requires-Dist: cached-property (==1.5.2); extra == "dev"
Requires-Dist: cerberus (==1.3.2); extra == "dev"
Requires-Dist: certifi (==2020.12.5); extra == "dev"
Requires-Dist: distlib (==0.3.1); extra == "dev"
Requires-Dist: flake8 (==3.8.4); extra == "dev"
Requires-Dist: iniconfig (==1.1.1); extra == "dev"
Requires-Dist: mccabe (==0.6.1); extra == "dev"
Requires-Dist: orderedmultidict (==1.0.1); extra == "dev"
Requires-Dist: pathspec (==0.8.1); extra == "dev"
Requires-Dist: pep517 (==0.9.1); extra == "dev"
Requires-Dist: pipenv-setup (==3.1.1); extra == "dev"
Requires-Dist: pipfile (==0.0.2); extra == "dev"
Requires-Dist: pylint (==2.6.2); extra == "dev"
Requires-Dist: pytest (==6.2.2); extra == "dev"
Requires-Dist: regex (==2020.11.13); extra == "dev"
Requires-Dist: requests (==2.25.1); extra == "dev"
Requires-Dist: typed-ast (==1.4.2); extra == "dev"
Requires-Dist: wrapt (==1.12.1); extra == "dev"
Requires-Dist: plette[validation] (==0.2.3); (python_version >= "2.6" and python_version not in "3.0, 3.1, 3.2, 3.3") and extra == "dev"
Requires-Dist: pyparsing (==2.4.7); (python_version >= "2.6" and python_version not in "3.0, 3.1, 3.2, 3.3") and extra == "dev"
Requires-Dist: toml (==0.10.2); (python_version >= "2.6" and python_version not in "3.0, 3.1, 3.2, 3.3") and extra == "dev"
Requires-Dist: attrs (==20.3.0); (python_version >= "2.7" and python_version not in "3.0, 3.1, 3.2, 3.3") and extra == "dev"
Requires-Dist: idna (==2.10); (python_version >= "2.7" and python_version not in "3.0, 3.1, 3.2, 3.3") and extra == "dev"
Requires-Dist: lazy-object-proxy (==1.4.3); (python_version >= "2.7" and python_version not in "3.0, 3.1, 3.2, 3.3") and extra == "dev"
Requires-Dist: packaging (==20.9); (python_version >= "2.7" and python_version not in "3.0, 3.1, 3.2, 3.3") and extra == "dev"
Requires-Dist: pluggy (==0.13.1); (python_version >= "2.7" and python_version not in "3.0, 3.1, 3.2, 3.3") and extra == "dev"
Requires-Dist: py (==1.10.0); (python_version >= "2.7" and python_version not in "3.0, 3.1, 3.2, 3.3") and extra == "dev"
Requires-Dist: pycodestyle (==2.6.0); (python_version >= "2.7" and python_version not in "3.0, 3.1, 3.2, 3.3") and extra == "dev"
Requires-Dist: pyflakes (==2.2.0); (python_version >= "2.7" and python_version not in "3.0, 3.1, 3.2, 3.3") and extra == "dev"
Requires-Dist: python-dateutil (==2.8.1); (python_version >= "2.7" and python_version not in "3.0, 3.1, 3.2, 3.3") and extra == "dev"
Requires-Dist: six (==1.15.0); (python_version >= "2.7" and python_version not in "3.0, 3.1, 3.2, 3.3") and extra == "dev"
Requires-Dist: vistir (==0.5.2); (python_version >= "2.7" and python_version not in "3.0, 3.1, 3.2, 3.3") and extra == "dev"
Requires-Dist: chardet (==4.0.0); (python_version >= "2.7" and python_version not in "3.0, 3.1, 3.2, 3.3, 3.4") and extra == "dev"
Requires-Dist: click (==7.1.2); (python_version >= "2.7" and python_version not in "3.0, 3.1, 3.2, 3.3, 3.4") and extra == "dev"
Requires-Dist: colorama (==0.4.4); (python_version >= "2.7" and python_version not in "3.0, 3.1, 3.2, 3.3, 3.4") and extra == "dev"
Requires-Dist: pip-shims (==0.5.3); (python_version >= "2.7" and python_version not in "3.0, 3.1, 3.2, 3.3, 3.4") and extra == "dev"
Requires-Dist: requirementslib (==1.5.16); (python_version >= "2.7" and python_version not in "3.0, 3.1, 3.2, 3.3, 3.4") and extra == "dev"
Requires-Dist: tomlkit (==0.7.0); (python_version >= "2.7" and python_version not in "3.0, 3.1, 3.2, 3.3, 3.4") and extra == "dev"
Requires-Dist: wheel (==0.36.2); (python_version >= "2.7" and python_version not in "3.0, 3.1, 3.2, 3.3, 3.4") and extra == "dev"
Requires-Dist: urllib3 (==1.26.3); (python_version >= "2.7" and python_version not in "3.0, 3.1, 3.2, 3.3, 3.4" and python_version < "4") and extra == "dev"
Requires-Dist: astroid (==2.4.2); python_version >= "3.5" and extra == "dev"
Requires-Dist: black (==19.10b0); python_version >= "3.6" and extra == "dev"
Requires-Dist: isort (==5.7.0); (python_version >= "3.6" and python_version < "4.0") and extra == "dev"
Provides-Extra: dev
Description-Content-Type: text/markdown
[Description omitted; length: 853 characters]

WHEEL

Wheel-Version: 1.0
Generator: bdist_wheel (0.36.2)
Root-Is-Purelib: true
Tag: py2-none-any
Tag: py3-none-any

RECORD

Path Digest Size
anlib/__init__.py sha256=CuSiswAO2BLrp4kCWNtwfK2Je89xOJWrCWiuLGBMxIY 20
anlib/helpers.py sha256=tyZDqU73Xt-eQnOwiJJj16AELNbhWF2rdDhWx6hjAls 876
anlib/main.py sha256=mS8OWk3gbmhZg4haAOAnO0l0TnCkDFYWzON5-DPPlqE 947
anlib-1.2.dist-info/LICENSE sha256=lUgGI3O4XA3t-YOnJZcfIX0PJN9RdMPGd9Kv_ZlKW3A 1069
anlib-1.2.dist-info/METADATA sha256=iaQkZTRflgbvjiaDYRxTbFMG5Z0o7H6bUK9Aly2ZQOg 6383
anlib-1.2.dist-info/WHEEL sha256=Z-nyYpwrcSqxfdux5Mbn_DQ525iP7J2DG3JgGvOYyTQ 110
anlib-1.2.dist-info/entry_points.txt sha256=Lsg_teOswMNjZ7I-oYJudgNRHclYxk5LDo7dEP7I7fY 43
anlib-1.2.dist-info/top_level.txt sha256=Gk_lVZSuhdJ5GiSdwKnAPrO49Rel6Ro8mrZIMtKzuyU 6
anlib-1.2.dist-info/RECORD

top_level.txt

anlib

entry_points.txt

anlib = anlib.main:main