requirementslib

View on PyPIReverse Dependencies (27)

1.5.16 requirementslib-1.5.16-py2.py3-none-any.whl

Wheel Details

Project: requirementslib
Version: 1.5.16
Filename: requirementslib-1.5.16-py2.py3-none-any.whl
Download: [link]
Size: 109896
MD5: fcfede8c5a259739de13f32d1d71db23
SHA256: 50d20f27e4515a2393695b0d886219598302163438ae054253147b2bad9b4a44
Uploaded: 2020-11-12 08:06:06 +0000

dist-info

METADATA

Metadata-Version: 2.1
Name: requirementslib
Version: 1.5.16
Summary: A tool for converting between pip-style and pipfile requirements.
Author: Dan Ryan
Author-Email: dan[at]danryan.co
Home-Page: https://github.com/sarugaku/requirementslib
License: MIT
Keywords: pipfile,requirements.txt,pip,requirementslib,pipenv,lockfile,dependency resolver,resolver,dependencies
Classifier: Development Status :: 5 - Production/Stable
Classifier: Intended Audience :: Developers
Classifier: License :: OSI Approved :: MIT License
Classifier: Programming Language :: Python
Classifier: Programming Language :: Python :: 2
Classifier: Programming Language :: Python :: 2.7
Classifier: Programming Language :: Python :: 3
Classifier: Programming Language :: Python :: 3.5
Classifier: Programming Language :: Python :: 3.6
Classifier: Programming Language :: Python :: 3.7
Classifier: Programming Language :: Python :: 3.8
Classifier: Programming Language :: Python :: Implementation :: CPython
Classifier: Programming Language :: Python :: Implementation :: PyPy
Classifier: Topic :: Software Development :: Build Tools
Classifier: Topic :: Software Development :: Libraries :: Python Modules
Classifier: Topic :: Utilities
Requires-Python: !=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*,>=2.7
Requires-Dist: appdirs
Requires-Dist: attrs (>=19.2)
Requires-Dist: cached-property
Requires-Dist: distlib (>=0.2.8)
Requires-Dist: orderedmultidict
Requires-Dist: packaging (>=19.0)
Requires-Dist: pep517 (>=0.5.0)
Requires-Dist: pip-shims (>=0.5.2)
Requires-Dist: plette[validation]
Requires-Dist: python-dateutil
Requires-Dist: requests
Requires-Dist: setuptools (>=40.8)
Requires-Dist: six (>=1.11.0)
Requires-Dist: tomlkit (>=0.5.3)
Requires-Dist: vistir (>=0.3.1)
Requires-Dist: scandir; python_version < "3.5"
Requires-Dist: contextlib2; python_version == "2.7"
Requires-Dist: vulture; extra == "dev"
Requires-Dist: flake8; extra == "dev"
Requires-Dist: rope; extra == "dev"
Requires-Dist: isort; extra == "dev"
Requires-Dist: invoke; extra == "dev"
Requires-Dist: twine; extra == "dev"
Requires-Dist: pre-commit; extra == "dev"
Requires-Dist: lxml; extra == "dev"
Requires-Dist: towncrier; extra == "dev"
Requires-Dist: parver; extra == "dev"
Requires-Dist: flake8-bugbear; python_version >= "3.5" and extra == "dev"
Requires-Dist: black; python_version >= "3.6" and extra == "dev"
Requires-Dist: mock; extra == "tests"
Requires-Dist: pytest; extra == "tests"
Requires-Dist: twine; extra == "tests"
Requires-Dist: readme-renderer[md]; extra == "tests"
Requires-Dist: pytest-xdist; extra == "tests"
Requires-Dist: pytest-cov; extra == "tests"
Requires-Dist: pytest-timeout; extra == "tests"
Requires-Dist: coverage; extra == "tests"
Requires-Dist: hypothesis; extra == "tests"
Requires-Dist: typing; python_version < "3.5" and extra == "typing"
Requires-Dist: mypy; python_version >= "3.4" and extra == "typing"
Requires-Dist: mypy-extensions; python_version >= "3.4" and extra == "typing"
Requires-Dist: mypytools; python_version >= "3.4" and extra == "typing"
Requires-Dist: pytype; python_version >= "3.4" and extra == "typing"
Requires-Dist: typed-ast; python_version >= "3.4" and extra == "typing"
Requires-Dist: monkeytype; python_version >= "3.6" and extra == "typing"
Provides-Extra: dev
Provides-Extra: tests
Provides-Extra: typing
Description-Content-Type: text/x-rst
[Description omitted; length: 11153 characters]

WHEEL

Wheel-Version: 1.0
Generator: bdist_wheel (0.34.2)
Root-Is-Purelib: true
Tag: py2-none-any
Tag: py3-none-any

RECORD

Path Digest Size
requirementslib/__init__.py sha256=dtAO3QvhC9gMCpwgcqo4pS4bKvE3Msjob43EH_wmEL0 488
requirementslib/environment.py sha256=BODXyKY_abzVQt7PGJlfl4UztywAzzpRaX_wW8PRbco 431
requirementslib/exceptions.py sha256=q9n7sPQIKdNH7f38sAtODpux1yBZuySbDPovJIQEwN8 3699
requirementslib/utils.py sha256=IMhK-oWw1nVv2iqJQ2a3uX0CY7BqZlL6-9_KqPaaPqo 25549
requirementslib/models/__init__.py sha256=iwhKnzeBJLKxpRVjvzwiRE63_zNpIBfaKLITauVph-0 24
requirementslib/models/cache.py sha256=VsWpAhr2prZcJ16daM7Us7gnRPgtML2mXeNl9vS8Ubo 11542
requirementslib/models/dependencies.py sha256=YFPdYt98-rHwsrIsSIRaz09fen4wcTIp6idp41BdMgw 25361
requirementslib/models/lockfile.py sha256=ISloCzSg9QFlGp1tc3ia0JPgrdwSBTBoHmNuf01wKcM 11186
requirementslib/models/markers.py sha256=epdyLfNgYa6zrIOAwdYSTeN1Q_jXIqohsH7lQ0jgPyw 26195
requirementslib/models/metadata.py sha256=IDkZtNBZ7IOwV8VNHZJeZhGI_jhOF9c8b4KxAyCLRK0 44119
requirementslib/models/pipfile.py sha256=TMxkjvtcUqctIuodOq0rMfxvg3Ql7Ps1x9cKXdfmyr4 14219
requirementslib/models/project.py sha256=746i_ZGn4FYR-_FjFYzF13fuY6dHSfjGIqfsDwDnVyk 7818
requirementslib/models/requirements.py sha256=qsW7D_tTqyApfH2mhxXQAwqzzFYk0jTb9DlkVetDpJc 120115
requirementslib/models/resolvers.py sha256=uzsMXtW8BDVqwnwUbyMuZGXRsB6tILkeBhn2lChLDdw 9546
requirementslib/models/setup_info.py sha256=1NWbImqFB0m2ob52PASwBezHD4-G4UXAcJwZQr4fmtg 71801
requirementslib/models/url.py sha256=oQ_lIUIkycwF9C9-lxnB93GmSKSFH5EK-_EVF3Sayl0 18637
requirementslib/models/utils.py sha256=RmlpH1P8QmP_HNppKLfXTc2_fQUq0P8LUHw31oGACCM 35594
requirementslib/models/vcs.py sha256=YM1hH-Z40VdCFP-S2IS4S2MrDbFkgeVM--AkKT84TLY 4881
requirementslib-1.5.16.dist-info/LICENSE sha256=-R7DVBemv_w_Ne7M942r0fnIk2A5PX5EOXzf4lG6S-Y 1072
requirementslib-1.5.16.dist-info/METADATA sha256=3-IbofWT11IughEyfW_saPyf0y_MX2t7BAIQPBA2uOw 14586
requirementslib-1.5.16.dist-info/WHEEL sha256=kGT74LWyRUZrL4VgLh6_g12IeVl_9u9ZVhadrgXZUEY 110
requirementslib-1.5.16.dist-info/top_level.txt sha256=62RzC-JqDN0Tka6aDiOwziXeW9gdtztzq2enS-Qu1yo 16
requirementslib-1.5.16.dist-info/zip-safe sha256=AbpHGcgLb-kRsJGnwFEktk7uzpZOCcBY74-YBdrKVGs 1
requirementslib-1.5.16.dist-info/RECORD

top_level.txt

requirementslib

zip-safe